IPv6状态下XBOX ONE经常无法下载游戏或更新解决方法

这段时间才开始,之前没事,稍微研究了下。

XBOX ONE下载会用以下两个链接

assets1.xboxlive.com
assets2.xboxlive.com

然后根据你的dns来解析到不同区域的服务器,这样下载速度会很快。IPv6状态下它解析会解析出IPv6的ip,速度应该会更快。

但是如果用国内的dns就会转到下面这个网址

win10fore.ndlmix.ourdvs.com

它的IPv6地址啊,一个都ping不通,这个不知用的哪个傻吊的服务器,可能以后会能用,但现在不行啊,它非要从那些不通的地址下载,还不带拐弯的。

临时解决办法:
路由器里编辑、添加
nano /etc/firewall.user

ip6tables -I FORWARD -d 2408:80f2:0:10::/32 -j REJECT –reject-with icmp6-adm-prohibited #也可以先在ssh里执行这一条,测试一下,行不行

应该是行的了,上面的两个assets建议用国内dns解析。如果win10fore又换ip,用dig检测一下,加到防火墙里就好了。

“推特总统”咋发推啊

呵呵,也只能呵呵。

Twitter为啥不用ipv6呢?google facebook IPv6多好弄好ipv6网络随便上,YouTube播放速度比国内的播放速度还快还超清,ipv6好啊。

他要闲的没事非得发推,这可咋办呢?

这个就有一点点烦。

首先最好有个可以正常访问推的vps,再最好有ipv6地址,我看除了国内公司开的VPS可能都有了,最好用国外公司开的吧。

A、VPS上装pdnsd 和ss都只开ipv6端口 #pdnsd配置看前几篇文章

ss
“server”:”你的服务器IPv6地址”,

B、本地路由器(反正我就是用openwrt 官网系统就好用的很)#先按前几篇文章配置好。

装支持ipv6的pdnsd和ss,这两个很好设置。用ipv6地址连接应该好些我感觉,看着长那就是爽啊。还装个ipset。

C、配置本地dnsmasq.d下g.conf
server=/twitter.com/127.0.0.1#53
ipset=/twitter.com/glist

#建议不要用通配符,把所有推的网址每一条都按上面的格式列上去。而且不要随便下载网上的列表都不合适的,有很多直接能上的你还通过这个费流量,自己按需添加就好,没多少。

D、把

ipset create glist hash:ip counters timeout 1200

iptables -t nat -A zone_lan_prerouting -p tcp -m set –match-set glist dst -j REDIRECT –to-port 本地ss开放的端口

iptables -t nat -A zone_tun1_prerouting -p tcp -m set –match-set glist dst -j REDIRECT –to-port ss的端口 #如果你想openvpn客户端也推就加这个 tun1根据你的定义修改,这样你手机在哪都能推了连你路由器即可。

放到路由器-系统-启动项里

重启路由器,这位总统就可以正常发推了。

关于能不能用别人的VPN免费或收费的,我觉得吧,你不知道以后会不会当总统啊,虽然你与VPN之间的联系有些许加密,但你的访问对于你的VPN来看是裸奔的,它可以收集你所有的访问信息,等你当了总统后,拿给你看看,然后就呵呵了。

另外如果VPS开了sshd远程服务,也只开IPv6地址吧,这样就少了很多扫描的傻逼。

windows 10 home版下建立DNS服务

这几天想在windows下使用pdnsd作为DNS服务端,网上搜到一个,但不支持ipv6,想用cygwin编译不成功,对于我这样没有编程技术的无法解决。

猛然想到windows 10不是有个linux子系统么。试了下,装上还真是好用啊,可以说是神器。

我的系统windows 10 home 版,如图设置后再在应用商店搜索ubuntu安装

装好后,在ubuntu里

命令
apt-get update
apt-get install pdnsd

编辑
nano /etc/pdnsd.conf

server_port=53; #这里为啥用53呢?因为我装了dnsmasq不能用啊,以后慢慢研究吧
run_ipv4=off;

重启服务即可。在本地网卡设置那里把dns改成手动 127.0.0.1 就行。其它机器用你机器的ip,或者在dhcp服务里设置分发都应该行。

我估计其它很多服务都可以正常使用,以后有时间研究研究。没有智能路由器的用这个试试。

异地享受上篇建立好的IPv6网络

这个就更简单,看前几篇文章,都做好了的话,只需要在OpenVPN服务器端,也就是路由器中的配置文件。

编辑openvpn
nano /etc/config/openvpn

config openvpn ‘sample_server’ #在server下加入如下三行

list push ‘route-ipv6 自定义一个内网IPv6网段::/64’ #注意:不要和路由器中原网段相同,但最好是内网网段
list push ‘route-ipv6 2000::/3’
option server_ipv6 ‘和上面一样::/64’

编辑firewall.user
nano /etc/firewall.user #加入如下三行

ip6tables -t nat -A POSTROUTING -s 和上面一样::/64 -j MASQUERADE
ip6tables -A forwarding_rule -i tun1 -j ACCEPT #tun1为openvpn的网卡名,按需要修改,如果有多个可以用tun+
ip6tables -A forwarding_rule -o tun1 -j ACCEPT #同上

重启服务即可。客户端连接后会分配到内网IPv6地址,就和本地网络中的设备一样,任意访问IPv6地址网络了。

XBOX ONE流畅看YouTube视频

墙出发点非常好,可以防止不健康的东西进来。但是管理的人出问题怎么办?FreeBSD,sf.net这些东西有段时期的被封,连7-ZIP也有无法访问的时候,这里面就有了利益,是不是给钱就能封想封的?这类事在这都不是事,x雷近期关了所有资源服务器,怕洋人爷爷知道把你告的倾家荡产啊,过段时间必然再开。什么狗日的x米,当年我看着好啊,国人骄傲啊,就在它论坛里提了些建议,好嘛,有一天把我贴全删了,我还傻着脸纳闷去问是不是服务器出问题了?没过多久它就出了段广告词,我操他妈,这不就是我写的嘛。就为这删我所有的贴,想要我送你也行,删我花时间花精力写的东西我就不大高兴咯。这样只会抄的公司走不长远。

我想如果我写出方法,可能会出个很大很大很大的洞,而且很难修补。但是我觉得,这个东西每个人都有自己的想法,你的也不见得对,况且还牵扯到利益在里面。如果你人工智能比较优秀,就不要用人来管,人变数太大,就跟自动驾驶车一样,大家都用自动驾驶的车就不会出事故,但是这又牵扯到利益,自动驾驶好东西也无法流通。

1080p不在话下,速度流畅,不通过任何违反中国国家政策法规的手段就能看。只用自己宽带流量即可,除了你自己的网费什么费都不用交。还有4K视频,看过这个,国内的的低速视频真心不想看,是他们服务器不行?不是,是没有竞争。

方法很简单,就是用IPv6

IPv6的地址就像沙子一般多是吗?每个设备都可以有自己的IPv6地址,并且可以互相访问这个概念对吗?谁知道呢。

以下方法不用有原生IPv6网络,能上IPv4网就行。

首先需要一个智能路由器,我用的系统是原版的Openwrt 15.05.1

最好先配置好dnsmasq服务,网路环境,什么的运营商就用贵的,看我前面的介绍DNS的两篇文章,其实是挺重要的,建议先看那两篇。

一、一般大家都用windows,那就拿它做客户端。
以管理员身份运行cmd(看图建个快捷方式就行,如果用dig之类的就不用管理员身份)

输入命令
route print -6

返回结果如果没有IPv6的路由表。

看看下面两个服务开了没有

然后在网卡设置那里把ipv6选项去掉,重启一下网卡。
再route print 应该就有了,这点要感谢微软啊,内置了这个东西。

记住下面需要管理员权限执行的命令,以后会用得到
netsh int teredo show state
netsh interface teredo set state client 服务器地址(可以域名可以IP),端口(任意服务器端开放的)

这样理论上你是可以通过teredo访问IPv6的ip,可以找个ip ping -6一下,看看通不通,通了就进行下一步。

我的网络环境,没有IPv6外部地址。客户端win10可以通过teredo ping通IPv6的ip。光猫拨号连路由器WAN口,所以路由器WAN和LAN口是不同网段的内网IP(IPv4)

二、
配置路由器,首先ssh到路由器

然后(ar71xx/nand 改成你路由器的。)
A、下载和安装
wget https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/nand/packages/oldpackages/miredo-client_1.2.4-3_ar71xx.ipk

wget https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/nand/packages/oldpackages/miredo-common_1.2.4-3_ar71xx.ipk

opkg update

opkg install miredo-*_1.2.4-3_ar71xx.ipk

opkg install 6to4

B、编辑network
nano /etc/config/network

config globals ‘globals’
option ula_prefix ‘dd之类的::/64’ #这个随便只要是内网的ipv6网段就行

config interface ‘lan’ #添加如下内容
option ra_default ‘1’
option ra_management ‘1’
option ip6assign ’64’

config interface ‘WAN6’
option _orig_ifname ‘eth0.2’ #应该和wan的一样
option _orig_bridge ‘false’
option proto ‘6to4’
option ipaddr ‘改成你的外网ipv4的ip’ #其实是无关紧要的可以是任意的外网ip

C、编辑firewall
nano /etc/config/firewall

config defaults
option output ‘ACCEPT’
option syn_flood ‘1’
option input ‘REJECT’
option forward ‘REJECT’
option disable_ipv6 ‘0’ #加上这个,以后再慢慢改防火墙,先调通

D、编辑sysctl.conf
nano /etc/sysctl.conf

net.ipv6.conf.default.forwarding=1
net.ipv6.conf.all.forwarding=1
net.bridge.bridge-nf-call-ip6tables=1

E、编辑dnsmasq.conf
nano /etc/dnsmasq.conf
#添加
dhcp-range=::1,::FFFF,constructor:br-lan,ra-names
enable-ra

重启路由器,如果你之前配置的dnsmasq(前两篇基础篇)没有问题的话,应该能ping通 ipv6.google.com了,wan6应该也有200x的IP出现。

windows的话要把网卡设置IPv6选中(上面测试时是取消了的)
这样客户端也能收到200x和ddx的ipv6地址,能够访问IPv6主页了。

所有有IPv6地址的网站可以直接访问,在dnsmasq里把ipv6 上级dns放上面会先返回IPv6地址。

分配的200x地址被封了怎么办,IPv6地址分配取决于服务器端,可以分配任何ip给客户端。看下面一条。
这里如果miredo服务器地址被封了怎么办,miredo提供server服务(也可以用其他服务端),可以在任意机器或路由器上配置,端口也可以任意改变,在客户端填正确的地址和端口即可。windows先用上面的管理员命令更改服务器测试。

任意这个词很重要。

如果大家愿意分享server服务器(本身看说明不占什么带宽和资源,请指正),能上IPv4的网,就有无法断开的ipv6 p2p的网络环境。

人人为我为人人

而我们心爱的XBOX ONE可以顺畅访问IPv6服务的app了,应该对联机也有帮助我想。

ixbox.cn

XBOX中EA游戏提示锁账号怎么办

橘子账号最好别用国内邮箱注册。

EA貌似每年会有一定时期锁一部分账号,理由主要是游戏中作弊。
如果你真的没有作弊,那么按下面的操作来解锁吧。

如图,按照选择会联络上ea的客服,TW可以用中文交流,当然你也可以直接选美国、英文客服。

一般锁账号问题,客服会帮忙把你的解释邮件转发给美国的处理机构。
所以你的解释信息最好用英文。他帮你转发后,你也可以自己再写一封邮件到该处理机构邮箱,注意要用英文编码UTF-8

内容写明你没有作弊,在哪里如何购买的该游戏,XBOX live号和橘子号之类的,并于什么时段玩过。

然后等消息。

有时一次是无法通过的,没关系,看清回复内容,按需修改,再接再厉,多来几次,只要你真的没有作弊,应该是有机会解锁账号的。
我之前也是发了2、3?次才解锁成功。

XBOX ONE硬盘坏了自己换也很易

XBOX ONE 基本和一台PC差不多,里面可能会坏的就是硬盘了,出现开不了机105 101之类的错误,应该就是硬盘出现问题了。
按照以下步骤应该可以解决问题。

A、确认是否硬盘损坏,先去xbox主页下载离线更新工具(注意:离线更新包必须比你现在xbox的系统新或者一样,如果xbox是预览版系统就需要等待微软更新离线包,一般需要1~3个月)按照它网页操作方法来,
还不行就下载ubuntu xbox那个换大硬盘工具包。

B、有可能是分区错乱,也可能是硬盘真坏。首先拆机,网上搜下,拆时取壳子时注意前面板的排线。
硬盘拿出来,插到台式机上(不要用USB硬盘盒,而需要用SATA连到PC主板上),测试一下。硬盘没坏、分区表错乱就用ubuntu xbox那个换大硬盘工具包重新分一下区,格式化一下,然后进行D。

C、购买新硬盘需要和原机硬盘容量相同,否则恢复时微软离线工具会把分区表搞乱,无法正常使用。

D、用下载回的ubuntu xbox换硬盘工具,做新硬盘(不需要两块硬盘)。
只做新硬盘那一步即可,再把离线更新包里的文件考到
system update那个盘下图那样放。完成后把硬盘插回xbox。

开机,不行的话,就离线更新包伺候,绝对行。